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Chapter 1 – General Description

Introduction
Since 1988 MICRO‑AIDE has provided the rail signal industry with a broad range of Event Recorders, 
Alarm Reporters and Data Loggers that vary significantly in capacity, size and features. The CWR, CAR 
and VDL families represents an extensive line of products that include a variety of useful and easy-to-use 
features favored by many technicians and maintainers.

In 2020 MICRO‑AIDE expanded its family of CWR devices with the introduction of its B-model Recorders. 
Currently the family consists of the CWR‑24B, CWR‑40B and CWR‑72B. With GEAB (Graphical Event 
Analyzer B-version) MICRO‑AIDE has now made the gathering, saving, viewing, analysis and plotting of 
CWR‑B Event Record data even easier. GEAB is a Windows 10®-based application that is fully compatible 
with all B-model Event Recorders. Working in a Windows® environment the user can take advantage of its 
intuitive Graphical User Interface (GUI).

GEAB can be quickly and easily installed. GEAB software is provided as a zip file, downloadable from 
the MICRO‑AIDE website. Once installed, a host of database preparation, printing and plotting features 
are made available to the user. GEAB can be used to access any B-model Recorder by establishing an 
Ethernet® connection to the Recorder.

All MICRO‑AIDE rail signal products, including GEAB, are designed to be easy to use and maintain. Each 
design is based upon the premise that value and reliability start with attention to detail and a concern 
for usability rather than needless complexity. Our goal in creating GEAB was to provide the rail signal 
industry with a valuable software tool that best complements our Recorders, while also filling the needs of 
technicians and maintainers.

Requirements
GEAB can be installed and run on a broad range of PC hardware types. However, it should always be 
installed on a PC running a 64-bit version of Windows 10. A complete list of requirements can be found in 
the section entitled “PC Requirements” on page 51.

Key Features
Listed in the following are some of the many features supported by GEAB.

•	 Fully compatible with MICRO‑AIDE CWR‑24B, -40B and -72B Event Recorders.

•	 A single file is used to install GEAB.

•	 Fully compatible with Windows 10 64‑bit operating systems.

•	 An unlimited number of Event Recorders can be configured for use with GEAB.

•	 Setup Databases can be modified using GEAB, even when offline with the Recorder.

•	 The Setup Database for each Recorder is automatically saved to the PC.

•	 Both Passwords and the Passcode are encrypted when Downloaded as a text file.
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•	 Data from the Recorders can be acquired locally (i.e., while on site) via an Ethernet connection or 
remotely via an Ethernet-based LAN connection.

•	 Each Recorder can be accessed via its assigned fixed IP Address or name.

•	 The Live Status Window displays the current state of each Recorder input. Simulated, multi-colored 
LEDs are used to indicate various signal states.

•	 The database parameters for any input can be viewed within the Live Status Window.

•	 Searching through the Event Record data for a particular combination of inputs states is facilitated 
by the use of eight Logical Equations.

•	 Logical Equations are entirely user-defined. Each yields a distinct Equation Output.

•	 Event Records can be viewed within GEAB either as text or as simulated pin plots within the Plot 
Window.

•	 Every Digital, Analog, Virtual and Alarm Input and Equation Output can be simultaneously plotted on 
screen.

•	 Event Records from System Input 1 (i.e., Power On / Off) are plotted on a separate Plotting Channel.

•	 Any input or Equation Output can be assigned to any Plotting Channel.

•	 Plotting Channels can be moved and relocated to any position within the Plot Window.

•	 Plotting Channels can be assigned colors to highlight data of special interest to the user.

•	 Flashing Event Records are plotted with a distinctive pattern for easy identification.

•	 Event Records that are viewed as text or on Plotting Channels can also be printed.

•	 Within the Plot Window, time measurement cursors can be positioned at any change in state.

•	 Also within the Plot Window, a context menu provides a comprehensive set of multi-level zoom-in and 
zoom-out controls.

•	 The mouse scroll wheel can also be used to zoom-in and zoom-out.

•	 Plot Window settings can be saved as a template and then reapplied to another plot at any time.

•	 Using the Ghostscript® application the Plot Window can be saved as an Adobe PDF® file or PNG im‑
age. It can then be annotated as the user may desire.

•	 An extensive HTML-based help document can be accessed directly within GEAB.

•	 The Real-time Plot feature provides a continuously updated, multi-channel view of each input. 
Available in a future release.

Software Modification History
Features have either been introduced or modified as the result of the following software modifications.

	 V1.00	 Initial release.

	 V1.01	 Within GEAB, the Administrative and Restricted Passwords and Passcode are encrypted and decrypted 
when Downloaded and Uploaded, respectively. Requires version 1.03 (or later) software in the Event 
Recorder.

	 V1.02	 Eight Logical Equations, each containing up to four variables, can be defined by the user. Each Logical 
Equation yields an Equation Output. Alarm Inputs, Equation Outputs and System Input 1 are now plotted. 
If a Setup Database has not been Downloaded for a selected Recorder, the factory default database is 
used and saved when attempting to edit a database. The vertical list of Recorders in the GEAB Window 
can now manually changed.
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	 V1.03	 Corrected the background tinting of the Edit > Edit Setup... command Window.

Event Recorder Software
GEAB is designed for compatibility with the latest B-model Recorder software. Conversely, in some very 
rare cases it will not fully support older Recorder software versions. For this reason MICRO‑AIDE advises all 
GEAB users to upgrade the software used by their Recorders whenever a new version of GEAB is installed. 
The latest versions of the GEAB software and B-model Recorder software are always available as down‑
loadable files from the MICRO‑AIDE website. There is no charge to the user for downloading files. The user 
is encouraged to contact MICRO‑AIDE directly if a question regarding GEAB and Recorder compatibility 
arises.

The current version of the software file used by each MICRO‑AIDE B-model Recorder and GEAB can be 
found at the following webpage. 
www.micro‑aide.com/support/downloads.html

About this Manual

Terms
This document refers to various features, settings, options and properties that are unique to GEAB and 
MICRO‑AIDE Event Recorders. This section provides a list of important terms and how each term is de‑
fined and used within the context of GEAB. Throughout this document, each term will be first-letter capi‑
talized (e.g., Recorder Data Folder). It may be helpful to think of terms using first-letter capitalization as 
the proper name of an important feature, setting, option or property and is specific to the use of GEAB.

Analog Input� ‑ any Analog Input supported by the Recorder that is connected to a battery or AC power 
source.

Cursor� ‑ a measurement tool provided in the Plot Window to indicate time differences and when an 
Event Record was time stamped.

Digital Input� ‑ any Digital Input supported by the Recorder that is connected to a set of relay contacts.

Download (or Downloaded)� ‑ the operation of copying the Recorder’s Setup Database file to GEAB.

Equation Output� ‑ the output that is the result of a Logical Equation defined within GEAB.

Event Record� ‑ a date and time stamped single line of text that contains all of the details related to the 
change in state of an Analog, Digital or Virtual Input.

GEAB Data Folder� ‑ a user-defined folder that is located on a PC drive and contains all of the Recorder 
data created or used by GEAB.

GEAB Window� ‑ the window that appears immediately after launching GEAB, inclusive of all commands 
and the list of Recorders.

Live Status Window� ‑ a separate window opened by GEAB that reports the real-time status of each 
input.

Logical Equation� ‑ defined within GEAB to find the simultaneous occurrences of several states shared 
among one to four inputs.

Menu Bar� ‑ the collection of grouped commands that appear near the top of the GEAB Window.

Off� ‑ as used by the Recorder and appears as a lower line on the assigned Plotting Channel.

On� ‑ as used by the Recorder and appears as an elevated line on the assigned Plotting Channel.

Passcode� ‑ the numeric code that controls access to the Recorder’s front panel and included within 
GEAB.

http://www.micro-aide.com/support/downloads.html
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Password� ‑ either the Administrative or Restricted Password as used by the Recorder and included with 
GEAB.

Plot Item� ‑ A Digital, Analog, Virtual or Alarm Input, Equation Output or System Input 1.

Plot Window� ‑ a separate window opened by GEAB that supports dozens of individual Plotting Channels.

Plotting Channel� ‑ the GEAB electronic equivalent of a single pen used by a physical pen recorder.

Recorder� ‑ unless otherwise stated, any MICRO‑AIDE CWR‑24B, CWR‑40B or CWR‑72B device.

Recorder Data Folder� ‑ the folder contained within the GEAB Data Folder that is used by a single 
Recorder to store various data files.

Setup Database� ‑ the collection of settings, parameters, names and labels used by the Recorder and 
used and maintained within GEAB.

System Input� ‑ used to report changes in state that are applicable to the Recorder as a whole (e.g., 
power, internal temperature, etc.).

Upload (or Uploaded)� ‑ the operation of copying the Setup Database file from GEAB to the Recorder.

Virtual Input� ‑ any Virtual Input supported by the Recorder that is used to perform logical analysis of the 
Event Record data.

Windows� ‑ specifically the Microsoft Windows 10 64‑bit operating system inclusive of all its features.

Conventions
Throughout this document there are frequent references to items that are meant to be understood liter‑
ally. These items can include, but are not limited to, commands, filenames and folder names. As an ex‑
ample of this convention, the Setup Database file named setup.txt is to be understood literally. It is not a 
reference to a text file that may be named setup.txt or something similar, rather it must be named setup.
txt. Bold text is used to highlight these items. The item referenced by the bold text is sufficiently important 
that it should be entered, clicked or selected exactly as it is. Doing otherwise may result in the failure of 
an important procedure.

Version
This document is intended to provide the user with comprehensive, easy-to-read instructions on how to 
install, set up and use MICRO‑AIDE’s GEAB software. This document refers to Version 1.03 of the GEAB 
software. The sample data and command details depicted were prepared using Version 1.03. The 
numerous screen shots were captured from a Windows 10 computer. Wherever possible, step-by-step 
instructions have been included. In the event the user has questions about any of the described proce‑
dures the user should contact MICRO‑AIDE for assistance.

Micro‑Aide Corporation 
685 Arrow Grand Circle 

Covina, CA 91722 
Tel: 626‑915‑5502    Fax: 626‑331‑9484 

E‑mail: support@micro‑aide.com

The MICRO‑AIDE “Material Return” and “Limited Warranty” policies can be found on the inside back 
cover of this manual.

The next chapter describes how to install and set up GEAB.

mailto:support%40micro-aide.com?subject=GEAB%20Support%20Request
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Chapter 2 – Installation and Setup

Introduction
This chapter describes how to properly install the GEAB software as provided and recommended by 
MICRO‑AIDE. A detailed description of how to set up GEAB is also provided.

Numerous screen shots and operating system references are included throughout this User Manual. 
Windows 10 was used exclusively in the preparation of this document.

Installation

Compatibility and Security
GEAB has been successfully installed and used on several 64‑bit versions of Windows 10. The procedure 
for installing GEAB is the same, regardless of the operating system version being used. GEAB should 
always be installed to a folder that incorporates the security and access restrictions desired by the user. 
This is particularly true of PCs configured for multiple users. The procedures for configuring these security 
features are outside the scope of this User Manual. The user may wish to confer with an I.T. specialist as 
regards this matter.

GEAB can be installed and used on any 64‑bit version of Windows 10 PC that is also running GEA. GEA will 
continue to be supportive of all its compatible recording devices.

Installation Procedure
Installing GEAB involves only a few simple steps. The Installation Procedure is similar to that used by many 
Windows applications. Less than 50 MBytes of disk space is required.

The following step-by-step procedure assumes that the geab_v103.zip file has been downloaded from 
the MICRO‑AIDE website and saved to the PC’s Desktop. The GEAB_V1.03.exe file should then be ex‑
tracted and also saved to the Desktop. The GEAB installation file includes all of the GEAB-specific files. 
Their installation is mandatory.

If the Installation Procedure is being used to install an updated version of GEAB, the previous version must 
be uninstalled first. Refer to the section entitled “Uninstall Procedure” on page 8.

Installing GEAB
1.	 Double-click the file named GEAB_V1.03.exe.

2.	 The following screen will be displayed. Click the button labeled Next > to proceed with the installa‑
tion.
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3.	 Set the appropriate radio button as required by multi-user or single-user operation. Then click the but‑
ton labeled Next > to proceed.

4.	 The Choose Install Location dialog box shown in the following will appear. The user must con‑
firm or select the folder where the GEAB application files will be installed. By default, the 
C: \ Program Files \ GEAB folder is preselected. However, the user can select a different folder.

MICRO‑AIDE strongly recommends that the user accept the preselected folder location for the installa‑
tion of GEAB.
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5.	 Click the Install button after the Destination Folder setting has been selected.

6.	 The installation will then proceed. The following dialog box will report the progress of the installation. It 
will complete automatically, typically after several seconds.

7.	 At the completion of the installation the following dialog box will appear. Click the button labeled 
Finish. GEAB is now installed and ready to be launched.

As a convenience, the user may wish to add a GEAB shortcut to the Desktop. 
 
The geab_v103.zip and GEAB_V1.03.exe files are of no further use. Both can be deleted from their saved 
location. However, do not delete any files from the C: \ Programs Files \ GEAB folder.
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Uninstall Procedure
The user may on occasion have need to uninstall GEAB. Uninstalling GEAB is described in the following 
section.

MICRO‑AIDE recommends that GEAB always be uninstalled before a new version of the application is 
installed.

Uninstalling GEAB
Complete the steps listed in the following section to uninstall GEAB.

1.	 Click the Windows Start button at the lower left corner of the Desktop.

2.	 Click the button labeled Settings as highlighted in the following screen.

3.	 A dialog box similar to the following will be displayed. Click the button labeled Apps.
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4.	 A long list of installed applications will be displayed. Scroll down as necessary to locate GEAB. Click 
the GEAB item. In the context menu that opens, click the button labeled Uninstall. In the subsequent 
dialog box that opens, confirm the operation by clicking the Uninstall button.

5.	 The uninstall will proceed as indicated by a dialog box that will auto-complete after a few seconds.

6.	 Finally, click the button labeled Close to complete the Uninstall Procedure.

If the GEAB Data Folder has been created as the result of a previous installation, its contents will not be 
affected as the result of the Uninstall Procedure. The Uninstall Procedure removes only the GEAB execut‑
able files.

Launching GEAB and Getting Help

Initial Launch
To launch GEAB double-click the Desktop icon or click the Windows Start Menu item named GEAB. If 
GEAB is being launched for the first time the screen labeled Figure 1 on page 10 will be displayed.

Near the top of the GEAB Window is a Menu Bar comprised of six commands. These commands function 
as common Windows commands. To execute a command simply click the command. In several cases 
subcommands will be displayed.

Getting Help
At the right end of the Menu Bar is the Help command. Click the Help command, followed by the Help 
subcommand (i.e., Help > Help). The user’s default Browser will be automatically launched. The Browser 
will then display the GEAB Help page. A portion of the GEAB Help page is depicted in Figure 2 on 
page 10. Firefox® was used in the example shown. The Help page contains an extensive collection of 
topics with links that can be clicked for ease of navigation. The Browser’s find text feature can also be 
used to quickly search for a particular topic or text phrase.

The GEAB Help page should be consulted often as it is very comprehensive and is always available 
whenever GEAB is running.
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Figure 1: GEAB Window - Initial Condition

Figure 2: GEAB Help Page
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Setting Up GEAB
Setting up GEAB involves two procedures. The first is to create and then target the GEAB Data Folder. 
The second is to install and then target the Ghostscript application. Both procedures are described in the 
sections that follow.

GEAB Data Folder

Creating and Naming the GEAB Data Folder

GEAB can be used to access an unlimited number of B-model Recorders. In the next chapter the proce‑
dure for adding a Recorder to the GEAB list of accessible Recorders will be described. For now it is impor‑
tant to understand that GEAB requires a main data folder that will eventually contain numerous subfold‑
ers. Each subfolder is uniquely associated with one Recorder. The subfolders are referred to as Recorder 
Data Folders. At the highest level of this folder hierarchy is the main GEAB Data Folder.

The most important step in setting up GEAB is to properly create the GEAB Data Folder. To do this, per‑
form the following steps.

1.	 Launch File Explorer within Windows.

2.	 Navigate to the user Documents folder or Desktop.

3.	 Right-click the Documents folder or Desktop to display the context menu.

4.	 Click the New > Folder command.

5.	 Change the folder name from New folder to GEABData.

The proper GEAB Data Folder has been created.

 Under no conditions should the GEAB Data Folder be located anywhere in the Program Files area of the 
PC’s C-drive. To be consistent with this documentation and the GEAB Help Page, MICRO‑AIDE strongly 
recommends that it be named GEABData and located either in the user’s Documents folder or on the 
Desktop. 

Targeting the GEABData Folder

To use the GEABData folder, GEAB must be made aware of its location. Do this by performing the follow‑
ing steps.

1.	 From the Menu Bar of the GEAB Window click the Edit > Setting... command. The following dialog box 
will be displayed.

Figure 3: Edit > Setting... Command

2.	 To the right of the edit box labeled GEAB Data Folder: click the button labeled Browse... .

3.	 In the folder selection dialog box that appears, navigate to the location of the GEABData folder and 
select it.

4.	 In the folder selection dialog box click the button labeled Select Folder. The dialog box will close 
automatically.

5.	 As depicted in the following figure, the dialog box from the first step will reappear with the location of 
the GEABData folder listed.
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Ghostscript Application
A key feature of GEAB is the ability to plot Event Record data from Digital, Analog, Virtual and Alarm 
Inputs as well as Equation Outputs. The Plot Window is the subject of Chapter 6. The Plot Window 
can be configured in a variety of ways to suit the user’s needs. Once configured, it can be converted 
and exported as a PDF or PNG file. Both file types can be annotated with labels and graphics that draw 
attention to an item of interest to the viewer. The annotation can be performed using a PDF editor (e.g., 
Adobe Acrobat®) or photo editor (e.g., Adobe Photoshop®).

The Plot Window conversion operation is performed by an application known as Ghostscript®. For GEAB 
to use Ghostscript the application must be installed and then targeted. Both procedures are described in 
the following two sections.

Downloading and Installing Ghostscript

To download the current version of Ghostscript, start by clicking the following webpage link: 
https://www.ghostscript.com/download/gsdnld.html.

In the row labeled Ghostscript 9.54.0 for Windows (64 bit) click the link labeled Ghostscript AGPL Release. 
Clicking the link will download the gs9540w64.exe file. Double-click the .exe file to proceed with the 
installation of Ghostscript.

Do not install Ghostscript anywhere other than as described in the installation procedure. At the comple‑
tion of the installation, this can be confirmed by locating the Ghostscript folder named gs in the Program 
Files folder of the PC’s C-drive. 
 
The version reference of 9.54.0 will vary as new releases of Ghostscript are made available.

Targeting Ghostscript

With Ghostscript installed, it can now be targeted for use within GEAB. Do this by performing the following 
steps.

1.	 The following dialog box may already be displayed. If not, from the Menu Bar of the of the GEAB 
Window click the Edit > Setting... command.

2.	 To the right of the edit box labeled Ghostscript exe: click the button labeled Browse... .

3.	 In the File Explorer dialog box that appears, navigate to the following file location: 
C: \ Program Files \ gs \ gs9.54.0 \ bin \ gswin64c.exe.

It is vitally important to select the proper file. Select the file named gswin64c.exe NOT gswin64.exe.

4.	 With the proper file selected click the button labeled Open.
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5.	 The previous dialog box will close automatically and the following GEAB dialog box will reappear with 
a file specification listing the proper Ghostscript executable file.

6.	 Finally, to complete this procedure click the button labeled OK.

GEAB is now set up to make use of a properly defined GEAB Data Folder and the Ghostscript applica‑
tion.

This completes the chapter on how to install and set up GEAB. The next chapter describes how to assign 
an Event Recorder for use with GEAB.
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User Notes
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Chapter 3 – Assigning an Event Recorder

Introduction
This chapter describes how to assign a B-model Recorder for use within GEAB. For the sake of simplicity 
and clarity the CWR‑72B Event Recorder is used consistently in the examples cited in this chapter.

Assigning an Event Recorder
Start by launching GEAB by double-clicking its Desktop icon. The GEAB Window shown in the following 
will be displayed.

Figure 4:  GEAB Window - Initial Condition

Before proceeding make sure that the GEAB Data Folder has been created. Refer to the section entitled 
“GEAB Data Folder” on page 11.

Commands are selected and various controls and activities are invoked from within the GEAB Window. 
In the center of the window is a blank area. The Recorders that GEAB will be used to access, acquire 
data from and plot the acquired data will be listed in this area.

To assign a Recorder within GEAB perform the following steps.

1.	 From the GEAB Menu Bar click the Edit > Add Recorder command. The following dialog box will be 
displayed.

Figure 5: Edit > Add Recorder Command

2.	 In the edit box labeled Recorder ID: enter the Recorder’s assigned Unit Name. The first twenty char‑
acters of the Unit Name appear on the fourth line of the Recorder’s OLED display.

3.	 In the drop-down list box labeled Recorder Type: select the correct Recorder (i.e., CWR‑24B, CWR‑40B 
or CWR‑72B).
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4.	 The Recorder’s assigned fixed IP Address or URL name must be entered in the edit box labeled IP 
Address / URL:.

5.	 In the edit box labeled Port: enter 8080.

6.	 In the edit box labeled Password: enter the Recorder’s Administrative or Restricted Password.

Using the Recorder’s Restricted Password within GEAB will limit the user’s ability to make changes to the 
Recorder’s working Setup Database.

7.	 Finally, accept the new settings by clicking the button labeled OK. The new Recorder will be added 
to the list of Recorders accessible to GEAB.

The following screen depicts a GEAB Window with one Recorder assigned.

Figure 6: GEAB Window - Typical Recorder Entry

Use the Edit > Add Recorder command again to assign additional Recorders as required.

Editing an Event Recorder
If circumstances change, it may become necessary to modify the GEAB settings for a specific Recorder. 
The Edit  > Edit Recorder command can be used for this purpose. To change the settings perform the fol‑
lowing steps.

1.	 Within the GEAB Window, single-click the Recorder of interest to select it. It will be highlighted as 
shown in the following figure.

Figure 7: GEAB Window - Recorder Selected

2.	 Click the Edit > Edit Recorder command. A dialog box similar to the following will be displayed.

Figure 8: Edit > Edit Recorder Command
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3.	 Single or multiple settings can be changed just as they were added using the Edit > Add Recorder 
command. Click the button labeled OK to save the changes and complete the procedure.

Changing the Event Recorder List
Over time it’s likely that several Event Recorders will be listed in the GEAB Window. The user may wish 
to change the vertical top-to-bottom order in the which the Recorders are listed. To change the order 
perform the following steps.

1.	 Position the mouse over the Recorder entry that needs to be relocated.

2.	 Click and hold the left mouse button. The Recorder entry will be highlighted.

3.	 Without releasing the mouse button, drag the mouse to a preferred location in the list. It’s new posi‑
tion will be dynamically desplayed.

4.	 Release the mouse button to comple the relocation.

Deleting an Event Recorder
Eventually a Recorder may be removed from service or relocated. In this case the Recorder should be 
removed from within GEAB. To delete a Recorder perform the following steps.

1.	 Single-click the Recorder to be removed. It will be highlighted as shown in Figure 7 on page 16.

2.	 Click the Edit > Delete Recorder command. The Recorder entry within GEAB will be immediately re‑
moved. A dialog box similar to the following will be displayed.

3.	 If the button labeled Yes is clicked, the Recorder Data Folder associated with the selected Recorder 
will be removed. Click the button labeled No to leave the folder and its contents intact.

Proceed with caution before confirming the data deletion in the previous dialog box. Once deleted, 
the Recorder Data Folder and its contents cannot be recovered. Saved Event Recorder data, the Setup 
Database and plots will all be permanently lost.

Recorder Data Folders
With every Recorder that is assigned within GEAB a unique folder is added to the GEAB Data Folder. Only 
one folder can be added. It is named directly from the contents of the Recorder ID: edit box listed in 
the Edit > Add Recorder command. Refer to the section entitled “Assigning an Event Recorder” on page 
15.

Under no circumstances should the user outside of GEAB rename, relocate or delete a Recorder Data 
Folder. Doing so severs the GEAB tie to the folder. GEAB will no longer be able to access the Recorder 
Data Folder, rendering the Recorder useless within GEAB.

Figure 9 on page 18 depicts a File Explorer view of the GEAB Data Folder (named GEABData) which 
includes three assigned Recorders. Each Recorder is uniquely named as previously described. In this 
example, if the Edit > Delete command is clicked and the user confirms the deletion of the Recorder Data 
Folder, one of these folders will be permanently removed.
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Figure 9: Typical GEAB Data Folder

This completes the chapter on how to assign a Recorder for use within GEAB. The next chapter describes 
how to prepare a Recorder’s Setup Database by accessing it using GEAB.
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Chapter 4 – Preparing a Setup Database

Introduction
An Event Recorder can be configured in a variety of useful ways that allow it to best suit the intended 
application. The Unit Name, Input Names, Input Identifiers and Event Names can be used to add clarity 
to the Event Record data. Additionally, the Detection Times, Speed Monitor and Flash Measurement 
parameters directly control the Recorder’s operation. Collectively these parameters are referred to as 
the Setup Database.

The Setup Database can always be established while online with the Recorder. In this case the user 
interacts directly with the user interface of the Recorder. GEAB provides an alternative to this method. 
Instead, the user can create the entire Setup database within GEAB while offline. After the Setup 
Database is created it is saved to a disk and can then be Uploaded to the Recorder.

This chapter describes how a typical Setup Database can be Downloaded, edited, saved and 
Uploaded. A CWR‑72B Event Recorder is used in the examples that follow.

Downloading the Setup Database
GEAB allows the user to edit the existing database resident in the Recorder. It follows that to edit the 
Recorder’s database, first a copy of its installed database must be acquired from the Recorder. To ac‑
quire a copy of the database perform the steps listed in the following.

1.	 Select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the Access > Download Setup command from the Menu Bar.

3.	 GEAB will attempt to connect with the selected Recorder. If it is able to connect with the Recorder, it 
will confirm the Download by displaying the following dialog box.

Conversely, if it is unable to do so (e.g., network outage, wrong IP Address, etc.) the following dialog 
box will be displayed. Another attempt should be made after the problem has been resolved.

4.	 If successful, a copy of the Recorder’s Setup Database will be saved to the Recorder Data Folder. 
The file will be named setup.txt. Complete the procedure by clicking the button labeled OK.
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Viewing the Setup Database
Provided GEAB has a copy of the setup.txt file, the Setup Database can be viewed at any time. To view 
the database perform the following steps.

1.	 Using the mouse, select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the View > View Setup Database command.

3.	 GEAB will create and save a document named setupdatabase.txt. The document will be opened 
using Notepad. The following shows a portion of the text file listing the Recorder’s System Parameters. 
Both Passwords and the Passcode are not readable as they have been replaced with asterisk char‑
acters.

Figure 10: Partial View of setupdatabase.txt Document

4.	 The setupdatabase.txt file can then be copied, renamed or printed if a hardcopy is required.

5.	 Close Notepad to close the file. The user is then returned to the GEAB Window.

The setupdatabase.txt file is strictly for viewing purposes. It is not used by GEAB. Instead, GEAB uses the 
setup.txt file. Both files can be found in the Recorder Data Folder.

Editing the Setup Database
If the user has access (remotely or locally) to the Recorder the installed Setup Database should be 
Downloaded. Refer to the section entitled “Downloading the Setup Database” on page 19. To edit 
a Downloaded and saved database follow the procedure entitled “Editing a Previously Downloaded 
Database File” on page 21.

If the user does not have access to the Recorder because the LAN is not yet available or local access 
is not possible, a Setup Database can nevertheless be prepared while offline with the Recorder. In this 
case, follow the procedure entitled “Editing the Factory Default Database File” on page 21.
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Editing a Previously Downloaded Database File
Once a copy of the Recorder’s Setup Database file is saved, GEAB can be used to edit the file while off‑
line with the Recorder. Perform the following steps to edit the database.

The entire Setup Database is saved in a file named setup.txt and located in the Recorder Data Folder. As 
a text file, it can be edited using any text editor application. The file uses a specific set of syntax rules that 
must not be violated. If the user elects to modify the setup.txt file directly, care must be exercised not to 
create a corrupted file.

1.	 Using the mouse, select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the Edit > Edit Setup... command from the Menu Bar. If the setup.txt file is located, a multi-tab 
dialog box similar to the following will be displayed.

Figure 11: Edit > Edit Setup... Command

3.	 To begin editing, first select a tab. In Figure 11 on page 21 the System tab is selected. It displays 
the Recorder’s System Parameters. Other tabs contains the settings for related settings (e.g., Input 
Names).

4.	 Change any settings as required. Changes must be made consistent with the requirements of the 
Recorder and the intended application. A complete explanation of each Setup Database setting 
can be found in the Recorder’s User Manual.

5.	 Click the button labeled OK to save the changes and close the dialog box.

The new database file can now be Uploaded to the Recorder. Refer to the section entitled “Uploading 
the Setup Database” on page 23.

Editing the Factory Default Database File
If a copy of the Recorder’s working Setup Database file is not available, the factory default database 
can be edited instead. Once fully edited, it can then be installed sometime later. With this procedure, 



GEAB User Manual

22 Micro‑Aide

4

the user can work entirely offline with the Recorder. Perform the following steps to edit the factory default 
database.

1.	 Using the mouse, select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the Edit > Edit Setup... command from the Menu Bar. The following dialog box will be displayed.

Figure 12:  Edit > Edit Setup... Command ‑ No Database File

3.	 To proceed with editing the factory default database file click the Yes button. The following multi-tab 
dialog box will be displayed.

Figure 13: Editable Factory Default Database

If the No button is clicked in the preceding step, the user will have to forego preparing a Setup Database 
file until such time as the Recorder can be accessed either remotely or locally.

4.	 To begin editing, first select a tab. In Figure 13 on page 22 the System tab is selected. It displays 
the Recorder’s System Parameters. Other tabs contains the settings for related settings (e.g., Input 
Names).

5.	 Change any settings as required. Changes must be made consistent with the requirements of the 
Recorder and the intended application. A complete explanation of each Setup Database setting 
can be found in the Recorder’s User Manual.

6.	 Click the button labeled OK to save the changes and close the dialog box.

The new database file can now be Uploaded to the Recorder. Refer to the next section.
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Uploading the Setup Database
The Setup Database file saved by GEAB will now contain new user-defined settings. However, the 
Recorder still retains its working database. To update the database used by the Recorder, perform the 
following steps.

1.	 Using the mouse, select the Recorder by clicking its entry in the GEAB Window.

2.	 Select the Access > Upload Setup command from the Menu Bar.

3.	 GEAB will attempt to connect with the selected Recorder. If it is able to login with the Recorder, it will 
confirm the Upload by displaying the following dialog box.

If GEAB is able to make a connection to the Recorder but the Password is incorrect, the following 
dialog box will be displayed. Another attempt should be made after the Password problem has been 
resolved.

To perform an Upload the Administrative Password must be used to login.

If a connection cannot be made (e.g., network outage, wrong IP Address, etc.) the following dialog 
box will be displayed. Another attempt should be made after the problem has been resolved.

Click the OK button to either complete or retry the Upload procedure.

This completes the chapter on how to prepare and edit a Setup Database. The next chapter describes 
how GEAB can be used to acquire data for the purposes of creating and viewing an Event Record 
report.
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User Note
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Chapter 5 – Event Record Reports

Introduction
GEAB can be used to access a Recorder and retrieve and save an Event Record report. Once saved 
the report can be viewed as text or plotted. Plotting is the subject of the Chapter 6. The Live Status 
feature provides information about the real-time status of each Recorder input. An Ethernet connection 
to the Recorder can be launched from within GEAB. All three of these features are described in the sec‑
tions that follow.

Using GEAB to Create and View a Report

Creating a Report
Before any Event Record data can be view or plotted, the data of interest must be acquired. Getting 
the data is referred to as creating a report. The procedure for doing so is described in the following steps.

1.	 Select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the Access > Query Events command from the Menu Bar.

3.	 A dialog box similar to the following will be displayed.

Figure 14: Access > Query Events Command

4.	 Select the range of dates and times the report should encompass. The drop-down list boxes associ‑
ated with the From: and To: settings provide access to a multi-year calendar. Selected dates will be 
listed in MM / DD / YY format. Click the appropriate up and down arrow buttons to select the time 
range in hours, minutes and seconds.

5.	 In the edit box labeled Save As: a complete file specification will be listed. At the end of the file 
specification is the name the file will be assigned. The name will be preassigned as events.bin. The 
folder the file will be saved to matches the Recorder Data Folder created for the selected Recorder. 
To change the filename click the Browse... button. In the dialog box that opens enter a new name in 
the edit box labeled File name:. The file extension must be left as .bin.

If the user elects to change the report’s filename the extension must be left as .bin. Additionally, the file 
must be saved to the appropriate Recorder Data Folder that is located within the GEAB Data Folder. For 
GEAB to view and plot report files, these rules must not be violated.

6.	 Complete the procedure by clicking the OK button. GEAB will attempt to connect with the selected 
Recorder. If it is able to connect with the Recorder, it will confirm the operation by displaying the fol‑
lowing dialog box.
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The report is now available for viewing.

Viewing a Report
Any saved report can be viewed as a plotted image or text file. The former is the subject of the next 
chapter. The latter is the subject of the following procedure. To view a report as text perform the follow‑
ing steps.

1.	 Select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the View > View Events command from the Menu Bar.

3.	 File Explorer will open in a dialog box similar to the following.

Figure 15: View >View Events Command

4.	 Click the report file to be viewed as text. In the previous figure only the events.bin file has been saved. 
Eventually the Recorder Data Folder will likely contain numerous .bin files. They can be viewed at any 
time and without limit.

To create an Event Record report the source of the data must always be a .bin file (e.g., events.bin, 
Incident_123456T_070121.bin).

5.	 To proceed, click the Open button. The dialog shown in Figure 16 on page 27 will be displayed.

6.	 The Select Inputs dialog box can be used to create a report that includes Event Record data from all 
inputs and Equation Outputs or a filtered report from selected inputs and Equation Outputs. Without 
making any selections, click the OK button to create an all-inclusive report. Using the shift + click and 
ctrl + click mouse operations create a filter setting comprised of a contiguous range or collection of 
noncontiguous ranges. The dialog box depicted in Figure 17 on page 27 shows an example of sev‑
eral noncontiguous ranges. Only the highlighted inputs will be included in the report.
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Figure 16: Select Inputs Dialog Box ‑ All Inputs Selected

Figure 17: Select Inputs Dialog Box ‑ Specific Inputs Selected
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7.	 Once the filter setting is defined, click the OK button to create the report and complete the proce‑
dure.

The report will be displayed as a Notepad document. A typical report for a selection of inputs is shown in 
Figure 18 on page 28.

Figure 18: Typical View > View Events Report

At the top of the report is listed the Event Recorder model, the range of dates and times, and the as‑
signed Unit Name of the Recorder. The remainder of the report includes single-line Event Record data 
meeting the range and input selection criteria.

The report will always be named after the source .bin file with an appended file extension of .txt. For 
example, the source binary file name of events.bin will yield a viewable text report file named events.bin.
txt. It too will be saved in the appropriate Recorder Data Folder. GEAB does not use the .txt report file for 
any purpose other than to present it to the user for viewing. It is not used to plot data. If a subsequent re‑
port is created and by default it is named events.bin.txt it will automatically overwrite an existing similarly 
named report.

Event Record formats are fully described in the Recorder’s User Manual. 
 
If the user wishes to save multiple Event Record reports created within GEAB, each new report should be 
renamed to prevent it from being eventually overwritten. As the report is a text file, the binary file exten‑
sion can be dropped. The report text file can be renamed or moved using Windows File Explorer. The 
following represents a new, but arbitrary, filename: 
Incident_123456T_070121.txt. The new name includes references to an incident, DOT Number, month, 
day and year.
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Viewing the Live Status
GEAB can be used to display the real-time status of all Recorder inputs that have a persistent state. Timer 
Inputs and many System Inputs are not characterized by a persistent state. To display the live status of 
inputs perform the following steps.

1.	 Select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the View > Live Status command from the Menu Bar.

3.	 GEAB will immediately acquire the working Setup Database used by the Recorder. It needs the Setup 
Database to properly interpret the real-time data it will eventually receive. The following dialog box 
will confirm the Setup Database has been acquired.

4.	 To proceed click the OK button in the previous dialog box.

5.	 In the case of a CWR‑72B, a screen similar to the following will be displayed. The Live Status screens 
for a CWR‑24B and CWR‑40B will include fewer inputs, but will otherwise be the same. Only the upper 
portion of the Live Status screen is depicted. Use the scroll bar to view other portions of the screen.

Figure 19: View > Live Status Command

6.	 When done viewing, close the Live Status screen by clicking the File > Quit command or clicking the 
X-mark in the upper right-hand corner.

At the very top of the Live Status screen is listed the Unit Name of the Recorder. Just below it is the Menu 
Bar of commands. For help specific to the Live Status feature, click the Help > Help command. An HTML 
page will open in the default Browser. The Help page is quite comprehensive. It includes numerous topics 
and links.

Just below the Menu Bar, the current internal temperature of the Recorder is listed. The current date and 
time are also reported. The time will be updated each second.
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The Live Status screen depicts the current state of each Digital, Analog, Virtual and Alarm Input. 
Additionally the state of Maintainer Mode is shown. Inputs are labeled by their assigned Input Identifier 
label. The screen is updated in real-time without user intervention.

The Live Status screen uses simulated LEDs to depict the state of each input. The various LED colors are 
explained in the following.

•	 Digital Input: Bright green indicates the input is in an On state. Dark green indicates the input is in an 
Off state.

•	 Analog Input: Red indicates the input is in an On state because its voltage level is outside an ac‑
ceptable range of values. Dark green indicates the input is in an Off state because its voltage level is 
within an acceptable range of values.

•	 Virtual Input: Bright green indicates the input has been evaluated as true and therefore considered 
to be in an On state. Dark green indicates the input has been evaluated as false and therefore con‑
sidered to be in an Off state.

•	 Alarm Input: Red indicates the alarm is active and therefore considered to be in an On state. Dark 
green indicates the alarm is not active and therefore considered to be in an Off state.

•	 Maintainer Mode: Red indicates that Maintainer Mode is On. Dark green indicates that Maintainer 
Mode is Off.

Connecting with a Recorder
A Browser connection to any Recorder can be launched from within GEAB. To do so, select the Recorder 
and then click the Access > Open in Browser command. The default Browser will be opened and a con‑
nection to the appropriate IP Address and Port will be attempted. A successful connection will display 
the Recorder’s Login screen. Connections initiated from within GEAB are indistinguishable from those 
made by launching the Browser outside of GEAB.

This completes the chapter on how to create and work with Event Record reports. The following chapter 
describes how to plot Event Record data.
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Chapter 6 – Plotting Event Record Data

Introduction
Perhaps the most frequently used feature of GEAB involves its ability to plot Event Record data. Plotting 
is performed within the confines of the Plot Window. Once acquired and saved, the record data can be 
plotted in a variety of ways. Additionally, the Plot Window content can be presented using a variety of 
useful features.

Acquiring the Record Data
Before any data can be plotted, GEAB must have access to one or more .bin data files. The 
Access > Query Events command is used for this purpose. This procedure is documented in the section 
entitled “Creating a Report” on page 25. Creating a report always results in a .bin data file being 
saved in the Recorder Data Folder. By default the data file will be named events.bin; however, the user 
may elect to name the file differently (e.g., Incident_123456T_070121.bin). Additionally and as explained 
in the next chapter, one or more data files may have been copied from a USB flash drive.

Regardless of the method used to acquire data files, only .bin data files can be plotted. Do not attempt 
to plot any file with an extension of .txt.

Plotting the Record Data
The procedure for creating an initial plotted view of any data file is quite simple. To do so perform the 
following steps.

1.	 Select the Recorder by clicking its entry in the GEAB Window.

2.	 Click the View > Plot Events command from the Menu Bar.

3.	 A dialog box similar to the following will be displayed. For the sake of simplicity only the setup.txt file 
and a single data file named events.bin are included in the Recorder Data Folder.

Figure 20: View > Plot Events Command
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4.	 Select the events.bin file (or another .bin data file if available) and then click the button labeled 
Open.

5.	 The Plot Window will open automatically. The following figure depicts a typical initial view.

Figure 21: Plot Window - Initial View

The initial Plot Window view shows all of the Event Record data as it would appear had a physical pin 
plotter been used. The first and last records are plotted at the left and right edges, respectively. The 
column along the left side includes all of the Plotting Channels aligned vertically. One Plotting Channel is 
assigned to plot one input or Equation Output (i.e., Plot Item). They are labeled with their assigned Input 
Identifier (e.g., WAX‑1T). In the remainder of this chapter a variety of features will be examined that can 
be used to change the view and content of the Plot Window. The same data file will be used throughout.

Changing the Plot Window View
The Plot Window shown in Figure 21 on page 32 contains a significant amount of data. However, for it 
to be useful the view will have to be changed. The following controls can be used for this purpose.

Zoom-in and Zoom-out
There are two ways to zoom-in or zoom-out within the Plot Window. Only the horizontal dimension will be 
changed in the new view. The vertical dimension will remain unchanged.

Scroll Wheel

Position the mouse in the area to be zoomed-in or -out. Rotate the mouse scroll wheel forward to zoom-
in or backwards to zoom-out. The area surrounding the location where the mouse is located will be 
zoomed-in or -out. Use the following context menu method if the mouse does not include a scroll wheel.
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Context Menu

The Plot Window can also be zoomed-in or -out by a set factor of 2, 4, 8 or 16. Each factor can be ap‑
plied multiple times. Locate the mouse in the area to be zoomed-in or -out. Right-click the mouse to 
display the following context menu. In the example shown the Plot Window is about to be zoomed-in by 
a factor of 16.

Figure 22: Plot Window - Context Menu - Zoom In 16x

In the following image, a specific area of the Plot Window has been zoomed-in by a factor of 16, again 
by 16, and finally by 8. The image now makes clear when various changes in state occurred. Digital Input 
22, with an Input Identifier of FLASH 1, includes a distinctive pattern to indicate a flash event. The labeled 
time ticks, located along the top and at the mid-section, can now be read.

Figure 23: Plot Window - Zoomed-In

In Figure 22 on page 33 the context menu shown includes a command labeled Zoom All. Click this 
command to restore the Plot Window to its initial view as shown in Figure 21 on page 32. The Plot 
Window can also be restored to its initial view by clicking the View > Zoom all command from the Menu 
Bar.
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Pan Left and Right
The Plot Window also includes a pan control. To pan, click and hold the left mouse button. Without 
releasing the mouse button, drag the mouse to the right to view more of the image on the left. Drag the 
mouse to the left to view more of the image on the right. Use either method as appropriate to center a 
portion of the image. The following screen shows the previous Event Record data centered within the 
Plot Window.

Figure 24: Plot Window - Centered Image

Assigning Colors to Plotting Channels
The context menu shown in Figure 22 on page 33 also includes the Color command. Use this feature to 
highlight a specific plotted line. To do so perform the following steps.

1.	 Position the mouse either on the Input Identifier (e.g., L OUT 1) or along any portion of the plotted line.

2.	 Right-click the mouse to open a context menu and then click the Color command.

3.	 The following color selection dialog box will open.
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Figure 25: Color Selection

4.	 Click any of the colors grouped as Basic colors: or create a custom color. Finally, click the OK button 
to complete the procedure.

In the following partial view, the Plotting Channels associated with Digital Input 21 (i.e. L OUT 1) and 
Digital Input 22 (i.e., FLASH 1) have been colored red and blue, respectively, to highlight their association 
and significance.

Figure 26: Plot Window - Plotting Channels with Color

Changing the Plot Window Content
In the previous sections the Plot Window was zoom-in, shifted horizontally, and color was added. These 
controls provide a better view of a portion of the Plot Window. In this section controls for changing and 
adding content to the Plot Window will be examined.

Moving Plot Items
In the initial Plot Window view Plot Items are assigned, from top to bottom, to Plotting Channels in the fol‑
lowing sequence. Refer to Figure 21 on page 32.

•	 Digital Inputs 1 through 20 / 32 / 64. The plotted line is high and low when the Digital Input is On and 
Off, respectively.

•	 Analog Inputs 1 through 4 / 8. The plotted line is high and low when the Analog Input is On (outside an 
acceptable range of operation) and Off (within an acceptable range of operation), respectively.

•	 Virtual Inputs 1 through 16 / 32. The plotted line is high and low when the Virtual Input is On (evaluates 
as true) and Off (evaluates as false), respectively.

•	 System Input 1 (Power On / Off). The plotted line is high and low when power to the Recorder is on 
and off, respectively.

•	 Alarm Inputs 1 through 20. The plotted line is high and low when the Alarm Input is in a Set state and 
Clear state, respectively.
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•	 Equation Outputs 1 through 8. Refer to the section entitled “Plotting Equation Outputs” on page 39. 
The plotted line is high and low when the Logical Equation evaluates as true and evaluates as false, 
respectively.

However, this sequence of Plot Items can be changed. This capability is useful if certain inputs that share 
a logical association would be better viewed as a contiguous group rather than being scattered verti‑
cally within the Plot Window.

A single Plot Item or a noncontiguous collection of items can be moved to any position. Perform the fol‑
lowing steps to move one or more items.

1.	 Position the mouse over the Input Identifier of a Plot Item to be moved. Click the mouse button to se‑
lect the item. The item will be highlighted in gray. Click additional items if more than one item needs 
to be moved. In the following image Digital Inputs 5, 19, 21 and 22 have been selected.

If a Plot Item is mistakenly selected, simply click it once again. The item will no longer be selected or 
highlighted.

Figure 27: Plot Window - Selected Plot Items to be Moved

2.	 Without clicking, simply reposition the mouse to where the selected items will be moved. The Input 
Identifier at the new location will be highlighted in blue.

3.	 Right-click the mouse to display the context menu shown in the following image. For the example 
cited the mouse was placed over the second Plotting Channel.
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Figure 28: Plot Window - Context Menu - Move Here

4.	 Finally, click the Move Here command to move the selected Plot Item(s). The item(s) will be moved 
directly above the blue highlighted item. This can be seen in the following image where Digital 
Inputs 5, 19, 20 and 21 now form a contiguous group directly below Digital Input 1.

Figure 29: Plot Window - Plot Items After Move

Plot Items will always be moved to the Plotting Channels directly above the blue highlighted Input 
Identifier. The remaining items will be relocated downward. No Plotting Channels will be vacated after a 
move. 
 
The vertical order of a selected noncontiguous collection of items will be retained after a move. The 
items will appear as a single, contiguous group with no intervening gaps.
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Setting and Using the Cursors
There may be an occasion when the user needs to know exactly when an event occurred. Additionally, 
it may be useful to know the time difference between two events. The dual Cursor feature provides both 
capabilities within the Plot Window. In the following procedure two Cursors will be set. Information related 
to each Cursor position will be explained.

A transition from low to high represents an On event. A transition from high to low represents an Off 
event. Cursors can only be set on transitions (i.e., when the plotted line changes vertically).

1.	 Position the mouse on the plotted line of the item of interest and then on a transition along the same 
line.

2.	 Right-click the mouse. The context menu shown in Figure 22 on page 33 will be displayed. From 
the context menu click the Cursor 1 > Set command. A green vertical line will extend through the Plot 
Window. The event transition will be marked by a green X character.

3.	 To set a second Cursor reposition the mouse on another transition of the same item or another item.

4.	 Right-click the mouse. The context menu shown in Figure 22 on page 33 will be displayed. From 
the context menu click the Cursor 2 > Set command. A red vertical line will extend through the Plot 
Window. The event transition will be marked by a red X character.

5.	 Along the bottom edge of the Plot Window will be four horizontally aligned boxes. Each box includes 
a time and date measurement. The first and second boxes indicate the time and date positions of 
Cursors 1 and 2, respectively. The third box is the time and date difference between Cursors 1 and 
2 calculated as Cursor 2 minus Cursor 1. A negative value simply indicates that Cursor 2 precedes 
Cursor 1. The fourth box is always presented, irrespective of either Cursor. It indicates the time and 
date position of the mouse within the Plot Window. Moving the mouse changes the reading immedi‑
ately.

In the following image green and red vertical lines and X characters indicate both Cursors have 
been set. The readings in the boxes at the bottom of the Plot Window have been updated accord‑
ingly.

Figure 30: Plot View - Cursors Set

6.	 To set Cursor 1 or 2 to a new position, use the appropriate Set command described earlier. To clear a 
Cursor use the Clear command from the same context menu.

Viewing Event Record Details
Since the basic Plot Window image is entirely derived from the Event Record data file (e.g., events.bin), 
it follows that all of the event details are available from within the window. This is best illustrated by the 
following procedure.

1.	 Position the mouse on the plotted line of the Plot Item of interest and then on a transition along the 
same line.
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2.	 Right-click the mouse. The context menu shown in Figure 22 on page 33 will be displayed. From the 
context menu click the Details command. A dialog box that includes complete information about 
the event will be displayed. As can be seen in Figure 31 on page 39 the physical Input Number 
(D22), time stamp, Input Name (FLASH RATE 1), Input Identifier (FLASH 1) and Event Name (FLASHOFF) 
are listed. The measured level and state of each Analog Input is also reported.

3.	 To close the dialog box click the OK button.

Figure 31: Plot Window - Event Record Details

Plotting Equation Outputs
In any rail signal application there may be fault conditions that can be defined by the simultaneous oc‑
currence of several input states. The Virtual Input feature allows the Recorder to continuously check for 
these occurrences in real-time. A change in state of any Virtual Input immediately logs an Event Record 
to memory. Properly configured, Virtual Inputs can be used to report a variety of fault conditions that 
can be defined by the logical conditions of one to four Recorder inputs.

Logical Equations, and their associated Equation Outputs, provide a similar capability within GEAB. The 
difference is that Logical Equations analyze the acquired Event Record data already saved within GEAB. 
Each Logical Equation has an Equation Output that can be plotted like any other Plot Item. Plotting 
Equation Outputs prevents the user from having to analyze the Plot Window content looking for a par‑
ticular combination of On and Off states shared by one or more inputs. By default, GEAB plots all of the 
Virtual Inputs and Equation Outputs.

GEAB includes support for eight Logical Equations and Equation Outputs. The procedure used to config‑
ure a Logical Equation involves two parts. They are described in the following two sections.
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Assigning the Variables

Each Logical Equation can be based upon the On and Off states of one to four inputs. Each input can 
be thought of as a variable within the Logical Equation. The first step is to assign the variables. To do so 
perform the following steps.

1.	 Open the Plot Window and have it display the Event Record data of interest.

2.	 From the Plot Window Menu Bar, click the Edit > Edit Equation command. The following dialog box will 
be displayed.

Figure 32: Edit > Edit Equations Command ‑ Assign Variables

The Logical Equations are numbered along the left side as E01 through E08. Each row contains the 
variables (one to four) for a single Logical Equation.

3.	 To assign an input as a variable click one of the drop-down list boxes in a row. The drop-down list box 
for the fourth variable of E08 is shown in the following example. The first and second variables have 
already been assigned as D1 and D5, respectively. The inputs can be assigned to variables in any 
order. Any variable can be skipped, which is the case with the third variable in the example. Any 
Digital, Analog or Virtual Input can be assigned as a variable.

4.	 Once the variables for the selected Logical Equation are assigned the variables for other Logical 
Equations can be assigned. To complete the assignment procedure click the OK button.
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Defining the Function

The variables for the Logical Equations should now be properly assigned. The second part of this proce‑
dure involves defining the logical function to be performed when evaluating the variables. It is the logi‑
cal function that defines when a Logical Input and its associated Equation Output evaluates as true or 
false (i.e., On or Off, respectively). Perform the following steps to define the logical function.

Continuing from step 4, the following dialog box will be displayed for the example cited. Only Logical 
Equation E08 has been configured. Its variables include Digital Inputs D1, D4 and D5.

Figure 33: Edit > Edit Equations Command ‑ E08 Variables Assigned

5.	 In the column labeled Function, click the button labeled edit... for the Logical Equation of interest. A 
dialog box similar to the following will be displayed.

Figure 34: Edit > Edit Equations Command ‑ Defining the Function

6.	 Towards the top of the dialog box, each of the assigned variables is identified by its physical input 
number (e.g., D01) and Input Identifier (e.g., WAX‑1T). In the example cited there are three variables. 
Among three variables there are eight different states. To define the function simply click the appro‑
priate check box in the column labeled Function.

7.	 In the following dialog box, E08 will evaluate as true whenever the WAX‑1T and ECWTD‑1T inputs are 
in the same state, but opposite of the ISLD‑1T input state.
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8.	 Click the OK button to complete the function definition. The user will be returned to the dialog box 
depicted in Figure 33 on page 41.

9.	 Additional Logical Equations and their functions can be configured as required. Otherwise, click the 
OK button to complete the procedure and return to the Plot Window.

Sample Equation Output Plot

By default the Equation Outputs of all eight Logical Equations are plotted at the bottom of the Plot 
Window. Like any Plot Item each Equation Output can be moved to any Plotting Channel location. The 
Equation Output E08 is plotted in the following screen. For clarity the content of the sample plot is limited 
to Digital Inputs D1, D4 and D5, along with E08. The latter is plotted in green.

Figure 35: Sample Plot of Equation Output E08

Configuring and then plotting E08 has made it immediately obvious when D1, D4 and D5 have collec‑
tively assumed a specific state of interest.

Plotting a Power Outage
The On and Off transitions of System Input 1 always reflect the state of power applied to the Recorder. By 
default System Input 1 is plotted within the Plot Window. Like any Plot Item it can be assigned a color and 
moved to any Plotting Channel location. In Figure 36 on page 43 System Input 1 is shown in blue at the 
very top. Digital Inputs 1 and 2 follow. Alarm Input 1 is toggling On and Off every 10 seconds. Cursors 1 
and 2 are set at the transition edges of System Input 1. They report that power was off for 24.00 seconds. 
No new events from any source can be logged to memory while power to the Recorder is off.
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Figure 36: Plot Window with Power On / Off Event

Of additional interest is that Alarm Inputs 2, 3 and 4 are not plotted. The states associated with these 
inputs are indeterminate both before and after the power off event. All other inputs share states that are 
either known or can be implied.

Saving and Restoring a Plot View
As shown in the previous sections of this chapter, the view within the Plot Window can be customized in 
a variety of ways. In many cases the Plot Items assigned to Plotting Channels and the colors assigned to 
channels will be used to plot other record data. As an example, a plot view customized for a particular 
type of incident investigation or maintenance review may be used repeatedly. Rather than duplicate 
the view each time, the view can be saved and then applied in the future to any Event Record data file.

Saving the View
To save a view, perform the following steps.

The zoom factor, pan position, Cursor positions and Event Record details dialog box are not saved in 
the following procedure. The plotted data within the Plot Window is not saved. The saved view can be 
thought of as a formatting template that can be applied to other record data.

1.	 Create a Plot Window view that has Plot Items ordered from top to bottom as required. Assign colors 
to the Plotting Channels to highlight them as required. Also, configure the Logical Equations as re‑
quired. All of these assignments will be saved.

2.	 Click the File > Save View command.

3.	 A dialog box similar to the following will be displayed.

Figure 37: File > Save View Command



GEAB User Manual

44 Micro‑Aide

6

4.	 In the edit box labeled File name: assign an appropriate file name (e.g., incident_view1_rpg.txt). 
The file created will include a .txt file extension. By default the file will be saved in the Recorder Data 
Folder of the selected Recorder.

5.	 To complete the save procedure click the Save button. The dialog box will close automatically.

Restoring the View
Once a plot view has been saved, it can be restored or applied to any data file. The procedure is de‑
scribed in the following steps.

1.	 The Plot Window must include plotted data.

2.	 Click the File > Restore View command.

3.	 A dialog box similar to the following will be displayed.

Figure 38: File > Restore View Command

4.	 Navigate to and select the saved view file of interest (e.g., incident_view1_rpg.txt).

5.	 Complete the procedure by clicking the Open button. The dialog box will close automatically. The 
plot view will now include the Plot Item ordering, color and equation assignments that were previ‑
ously saved.

Opening a Different Plot Window View
At any time, another data file can be opened and plotted within the existing Plot Window. The current 
view will be replaced by newly plotted data. Perform the following steps to create a new data plot.

1.	 Click the File > Open command.

2.	 A dialog box similar to the following will be displayed.

Figure 39: File > Open Command

3.	 The edit boxes labeled Event File and Setup File will reference the Recorder Data Folder for the 
Recorder originally selected within the GEAB application. Click the Browse... buttons to navigate to 
and select a different Recorder Data Folder. A .bin data file and its associated setup.txt file must both 
be selected. Verify that both edit boxes reference the same Recorder Data Folder.
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4.	 Finally, to create a new data plot click the OK button. The Plot Window will include an initial view 
that spans all of the new data. An example of an initial view is shown in Figure 21 on page 32. The 
various Plot Window controls can then be applied to customize the view as needed. The File > Restore 
View command can also be applied.

5.	 To complete the procedure and close the existing plot view click the FIle > Close command. The Plot 
Window will appear empty. A new data file can then be opened or the Plot Window can be closed.

Annotating a Plot View
A comprehensive incident investigation may require Event Record data be compiled in text as well as 
plotted form. For this reason, the view within the Plot Window can be printed and saved as a bit map 
image. As a bit map image it can be annotated with comments and explanations that may be helpful 
to other viewers. The process of annotating the image involves exporting the image in a suitable format 
and then adding comments and explanations. The annotations are drawn in as if the Plot Window image 
were a background on a canvas.

Before a Plot Window image can be exported, the Ghostscript application must be installed. Refer to the 
section entitled “Ghostscript Application” on page 12.

To add annotations perform the following steps.

1.	 Prepare the view within the Plot Window. The view should include the desired zoom factor, pan posi‑
tion, ordering, colors and cursors. It cannot include the Event Record details dialog box.

2.	 Click the File > Export PDF or File > Export PNG command. The Export PDF command includes two addi‑
tional subcommands which are Landscape and Portrait. In both cases the exported image will create 
a PDF document. The Export PNG command will create a bit map image in the form of a PNG file.

A dialog box similar to the following will be displayed.

Figure 40: File > Export PNG Command

3.	 In the edit box labeled File name: assign an appropriate name. By default the image file will be 
saved in the Recorder Data Folder for the Recorder that was originally selected. The file extension will 
be either .pdf or .png in accordance with the export command that was selected.

4.	 Complete the export by clicking the Save button. The dialog box will close automatically. The image 
file will be created and saved.

5.	 The .pdf or .png file can be opened in a variety of applications such as Adobe Reader®, Abode 
Acrobat®, Adobe illustrator®, Microsoft Paint and GIMP. Using the tools of the selected application, 
add notes, comments, explanations and artwork. When done remember to save the completed file. 
It can then be printed or copied.
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The steps necessary to include annotations to the exported image are beyond the scope of this User 
Manual. The documentation and support that accompanies the application should be reviewed.

Getting Plot Window Help
Help specific to the Plot Window is available. From the Menu Bar click the Help > Help command. An 
HTML page will open in the default Browser. The Help page is quite comprehensive. It includes numerous 
topics and links.

This completes the chapter on how to plot Event Record data. The next chapter describes how to prop‑
erly copy data to GEAB that was originally saved to a USB flash drive.
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Chapter 7 – Copying from a Flash Drive

Introduction
Every Recorder includes a USB Host Port. As a matter of convenience, it is arguably the most important 
feature of any CWR product. The Recorder’s front panel Save command allows the user to quickly copy 
Event Record data to a flash drive from a single date or selected time span. Using GEAB, the saved data 
can be viewed as text or plotted.

Data Folder Structures
Before the data saved to a USB flash drive can be properly copied for use by GEAB, it is important to 
understand how data is saved in the flash drive and within GEAB.

USB Flash Drive Data Folder
At the root of the flash drive, the USB Host Port feature will create a unique folder for each Recorder. The 
name of the folder will be taken from the first twenty characters of the assigned Unit Name. These are the 
same characters that appear on the fourth line of the Recorder’s OLED display. When the user executes 
a front panel Save command, three files are always written to the Recorder’s flash drive folder. The fol‑
lowing figure shows a typical example.

Figure 41: USB Flash Drive Data Folder

In the example shown, there are data files from two separate Save operations. A complete explanation 
of the folder’s structure and content follows.

•	 At the root of the flash drive will be one or more folders named after the first twenty characters of the 
Recorder’s Unit Name. The example contains only one folder named RED_MP12.76_LAKEDIV_.
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•	 Each Save operation always creates two Event Record data files. One file is a text file for report view‑
ing. The other is a binary file of the same data. This file is required by GEAB. Regardless of the file type, 
the name of each file is taken from the date of the first Event Record saved and the time and date 
the file was created. A .bin or .txt extension is then added to complete the filename. The sample files 
named 07‑02‑21@065936‑070321.bin and 07‑02‑21@065936‑070321.txt illustrate this naming conven‑
tion. Eventually, dozens or perhaps hundreds of data files will be saved to the same USB folder.

•	 Finally, each Save operation writes a copy of the Recorder’s working Setup Database. As each Save 
operation writes a setup.txt file it will automatically overwrite any existing similarly named file. In this 
way, the saved file is assured to be the latest version used by the Recorder. This file is the same file 
that GEAB saves when using its Download command. Refer to the section entitled “Downloading the 
Setup Database” on page 19.

In summary, each Save operation creates an Event Record data file in a form useful to GEAB and a 
setup.txt file. They are both saved in a folder uniquely associated with a specific Recorder.

GEAB Recorder Data Folder
GEAB always requires a GEAB Data Folder. Refer to “GEAB Data Folder” on page 11 for details. 
Furthermore, every Recorder added to GEAB will have a Recorder Data Folder named as part of the 
Edit > Add Recorder command. Refer to “Assigning an Event Recorder” on page 15. The following 
figure shows a typical Recorder Data folder for a Recorder with a Unit Name of  
RED_MP12.76_LAKEDIV_123456T. Notice there are more than twenty characters used in the folder name. 
The Recorder Data Folder is saved within the GEAB Data Folder which is named GEABData. Data folders 
for two other Recorders have also been created.

Figure 42: Typical Recorder Data Folder

For the sake of simplicity only two files have been saved within the Recorder Data Folder. One is named 
events.bin. It was created when the Access > Query Events command was used to acquire Event Record 
data. Refer to “Creating a Report” on page 25. The second file is named setup.txt. It is always saved 
when Event Record data is acquired or as part of a Download operation. The two files reflect the mini‑
mum content that GEAB requires to view and plot Event Record data.

Copying the USB Flash Drive Content
There are two procedures that will be explained in the following sections. The first is used if within GEAB 
an appropriate Recorder has already been assigned (i.e., added). The second procedure is used if GEAB 
does not have an assigned Recorder associated with the data to be copied.
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Copying to an Assigned Recorder
This procedure is quite simple. Using Windows File Explorer, copy the Event Record binary data file(s) to 
the Recorder Data Folder of the appropriate Recorder. Do the same for the setup.txt file so that GEAB 
has the latest Setup Database content. In the figure that follows, the 07‑02‑21@065936‑070321.bin and 
07‑05‑21@120004‑070521.bin files have been copied. The setup.txt file has also updated. The latter copy 
operation is optional if GEAB already has an up-to-date Setup Database file.

Figure 43: Recorder Data Folder - After Copying

In the example cited, the .txt files from the USB flash drive were not copied. GEAB does not use them. If 
the user wishes to view a text version of the Event Record data the View > View Events command can be 
used to recreate and save a viewable text document. Refer to “Viewing a Report” on page 26.

It is important to note that the Recorder involved in the previous example is associated with two slightly 
different folder names. In the USB flash drive the folder is named RED_MP12.76_LAKEDIV_. Within GEAB 
the folder of interest is named RED_MP12.76_LAKEDIV_123456T. The difference is inconsequential. What is 
important is that the .bin data file(s) and setup.txt file be present. The folders involved could be named 
ABC and XYZ. GEAB would not be impacted.

To avoid confusion MICRO‑AIDE recommends that the Recorder Data Folder within the GEAB Data 
Folder be named after the Recorder’s assigned Unit Name. The Recorder will always create a USB 
Data Folder using the first 20 characters of the same Unit Name. In this way it will be obvious into which 
Recorder Data Folder any USB files should be copied.

Copying to an Unassigned Recorder
In this procedure it is assumed that a GEAB Data Folder named GEABData already exists. However, a 
Recorder named RED_MP12.76_LAKEDIV_ has not as yet been assigned (i.e., added) within GEAB.

The first step in this procedure is also quite simple. Copy and paste the entire USB Data Folder associ‑
ated with the Recorder of interest into the GEABData folder. The .txt files and any .bin data files that are 
of no use or interest, respectively, can then be deleted. The following figure shows the final content of 
the GEABData folder and a Recorder Data Folder named RED_MP12.76_LAKEDIV_. Unnecessary text and 
binary files have not been deleted in the example depicted.
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Figure 44: New Recorder Data Folder - After Copying

The final step is to use the Edit > Add Recorder command to assign a new Recorder. Refer to “Assigning 
an Event Recorder” on page 15. In this case the name of the added Recorder must exactly match the 
folder name saved in the USB flash drive.

In the latter step, care must be taken not to add a Recorder with a name that is different than the USB 
Data Folder name. If the names are even slightly different a new differently named Recorder will be 
added. Only if the folder names match will GEAB be able to associate the Recorder with the correct 
data folder content.

Any Event Record .bin data files can now be viewed and plotted as if they had been acquired directly 
from within GEAB.

This completes the chapter on how to properly copy files from a USB flash drive so that they can be used 
by GEAB. The next chapter is an Appendix that lists important GEAB specifications and requirements.

Any comments the reader may have on how to improve this manual are welcomed. Comments should 
be forwarded to the Director of Marketing, MICRO‑AIDE Corporation.
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Appendix A – Technical Data

Specifications
Recorder Compatibility
Models
CWR‑24B, CWR‑40B, CWR‑72B

Quantity
Unlimited number of Recorders are supported

GEA Considerations
Use GEA for all other recording devices

GEAB and GEA can run concurrently on a single 
Windows 10 PC

Recorder Support
Setup Database
Recorder database can be Downloaded, edited 
and Uploaded

Viewed and saved as separate text file

Passwords and Passcode settings are encrypted

Reports
Event Record data from any time span can be 
accessed and saved

Any saved Event Record data can be plotted or 
used to create and save a report

USB Flash Drive
Setup Database and Event Record data can be 
copied and pasted directly within GEAB Data 
Folder

USB acquired data can be plotted or used in a 
report

Plot Window
Emulates
Multi-channel physical pin plotting machine

Plotting Channels
One per Digital, Analog, Virtual and Alarm Input 
of Recorder

One for each of 8 user-defined Equation Outputs

One for System Input 1 (Power On / Off)

Controls
Mouse scroll wheel supports zoom-in and zoom-
out

Context menu includes multiple zoom-in and 
zoom-out factors

Mouse click and drag feature supports pan-left 
and pan-right window movement

Any Plot Item can be assigned to any Plotting 
Channel

Plotting Channels can be highlighted with any 
color

Plotting Channels can be vertically repositioned 
anywhere to create groups of similar inputs

Event Record details provided with any change in 
input state

Dual cursors provide time position and difference 
details

Flashing events are highlighted with a different 
pattern

Live Status Window
Emulates
Single screen with multi-colored simulated LEDs 
used to indicate real-time status of inputs

Simulated LEDs
One per Digital, Analog, Virtual and Alarm Inputs

One for Maintainer Mode

Additional Data
Real-time clock and internal temperature of 
Recorder

Help
Separate help screens available for GEAB ap‑
plication, Plot Window and Live Status

Help screens are displayed as web pages in 
default Browser

PC Requirements
Operating System

Windows 10, 64-bit version

Documented using release version 21H1

Memory
Less than 50 MBytes of disk space

RAM as required by Windows 10

Browsers
Firefox, Google Chrome, Microsoft Edge

Ethernet Port
Required for local or remote access of Event Recorder data

Plot Window Annotating
Requires separate installation of Ghostscript

Documented using release version 9.54.0
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User Notes



Material Return

In the event the customer identifies a malfunction in any product, call or write MICRO‑AIDE and obtain a 
Return Material Authorization (RMA) number from the customer service department. Return the product 
to MICRO‑AIDE, freight prepaid, with a note (in-warranty repair) or a purchase order (out-of-warranty) for 
the repair listing the following information:

•	 RMA number issued by MICRO‑AIDE

•	 Return shipment address

•	 Name and e‑mail address or telephone number of person familiar with the problem

•	 Brief description of the problem (include any printouts that may have a bearing on the problem)

•	 Method of payment for repair costs (out-of-warranty)

•	 Send product to the following address:

Micro‑Aide Corporation 
685 Arrow Grand Circle 

Covina, CA 91722 
Tel: 626‑915‑5502    Fax: 626‑331‑9484 

E‑mail: support@micro‑aide.com

Limited Warranty

MICRO‑AIDE warrants its products to be free from defects in material and workmanship for a period of 
five (5) years from the date of shipment. This warranty is in lieu of any other warranty, expressed or im‑
plied. In no event shall MICRO‑AIDE be held liable for incidental or consequential damage resulting from 
(1) the use of any of its products, or (2) any alleged breach of this warranty provision. MICRO‑AIDE’s liabil‑
ity shall be limited to repairing or replacing, at its sole discretion, any defective product which is returned 
in accordance with the MICRO‑AIDE Material Return Policy.

Product that has been subjected to abuse, misuse, alteration, accident, lightning damage, neglect or 
unauthorized installation or repair shall not be covered by this warranty. MICRO‑AIDE reserves the right 
to make a final decision as to the existence of any failures and the cause of such failures. No warranty 
is made with respect to custom equipment or products produced to buyer’s specifications except as 
mutually agreed upon in writing.

mailto:support%40micro-aide.com?subject=GEAB%20Support%20Request


Micro‑Aide Corporation 
685 Arrow Grand Circle 

Covina, CA 91722 
Tel: 626‑915‑5502    Fax: 626‑331‑9484 

E‑mail: support@micro‑aide.com
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